Site Tools : System Requirements

System Requirements

Our site is optimized for Windows users with Internet Explorer 7 or higher.

Other operating systems and browsers will work, but may have limitations with some features of the site including our eCards and Print at Home products. Please see the individual help center pages for the System Requirements for specific products or features you are using.

Operating Systems

WINDOWS

  • Windows XP

  • Windows Vista

  • Windows 7

MAC

  • OSX (Leopard and Snow Leopard)

Browsers

Windows browsers:

  • Internet Explorer 7 or higher

  • Firefox 7.0 or higher

  • Chrome 15 or higher

MAC browsers

  • Safari Version 4.0 or higher

  • Firefox Version 7.0 or higher

  • Chrome 15 or higher

Please note that Internet Appliances (WebTV, MSNTV, etc.) are not compatible with many of the features on our site.

Please note that the AOL web browser is not compatible with our site.